Vision Release

Scheduled for Feb 4, 13:52 GMT  -  Feb 10, 13:37 GMT

Update

We are aware of an issue with Period 1 of Earned Recognition. We are currently working to fix this. In the meantime you can view your Earned recognition data on your Performance Dashboard. We will let you know as soon as the fix is released
Posted Feb 04, 2025 - 13:50 GMT

Scheduled

We are aware of an issue with Period 1 of Earned Recognition. We are currently working to fix this. In the meantime you can view your Earned recognition data on your Performance Dashboard. We will let you know as soon as the fix is released
Posted Feb 04, 2025 - 13:49 GMT